
SUPPLEMENTAL
MATERIALS

AutoCAD
and Its Applications

B A S I C S
Student Web Si te

Copyright by Goodheart-Willcox Co., Inc. Windows Explorer, page 1

Chapter 2

Windows Explorer
Windows Explorer, shown in Figure 2A-1, allows you to display and manage 

folders and fi les. To activate Windows Explorer, right-click on the Windows Start
button and select Explore from the shortcut menu. This supplement focuses on 
Windows Explorer provided with Windows XP. The material applies to other 
Windows operating systems, but will function and look slightly different.

The Windows Explorer Interface
The Windows Explorer interface includes a title bar, pull-down menu bar, 

standard toolbar, Address text box, Links bar, folders pane, contents pane, and 
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Figure 2A-1. The folders pane of Windows Explorer displays the folder tree. The contents pane 
displays the files and subfolders within the item selected in the folders pane.
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status bar. The Links bar is not active by default. Activate Windows Explorer 
tools using the pull-down menu, toolbar, shortcut menus, or keyboard keys. 
Figure 2A-2 provides quick identifi cation of the default items on the toolbar. 
Toggle the toolbar display on and off by selecting an option from the Toolbars
cascading menu of the View pull-down menu. A check mark next to a toolbar 
name indicates that it is active. You can add tools to the toolbar by selecting 
Customize... from the Toolbars cascading menu in the View pull-down menu.

Windows Explorer displays the contents of each drive in a tree, or graphic 
representation of folders and fi les. See Figure 2A-1. A vertical split bar divides 
Windows Explorer in half. The folders pane is the left half of the window and 
the contents pane is the right half. You can drag the split bar to the left or right 
to display more or less of the contents in each side of the window. Icons help to 
identify items as drives, folders, or fi les.

A small box containing a + or – symbol may precede device and folder icons 
in the folders pane. The + indicates that the folder contains additional folders, 
or subfolders. Pick the + symbol to expand the tree to display the next level 
of folders. Pick the – symbol to collapse, or hide, the display of subfolders. To 
display the contents of a folders pane item in the contents pane, pick the icon 
once. You must double-click folders in the contents pane to open them. An open 
folder automatically closes when you select and open a new folder.

PROFESSIONAL TIP
When you expand the folder tree to several levels, you can 
quickly back up to the previous level or branch by picking 
the Back button or pressing the [Backspace] key.

Go back to
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Toggles display of
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options

Figure 2A-2. Many file management options are available in the Windows Explorer toolbar.
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You can adjust the display of items in the content pane by selecting an 
option from the View pull-down menu or Views fl yout, or by right-clicking on 
any open area of the contents pane. The Thumbnails option displays icons for 
fi les and folders in large format. If a folder contains graphics fi les, thumbnail 
images of those fi les appear on the folder icon. The Tiles option displays each 
folder or fi le icon in a large format with the fi le name and selected informa-
tion below it. Pick Icons to display each folder and fi le icon in medium-size 
format with the folder or fi le name beneath it. Select List to represent fi les and 
folders with small icons with fi le names to the right. Files that do not fi t in the 
fi rst column appear in additional columns to the right. Use the horizontal scroll 
bar to display them. The Details method displays folders and fi les as a single 
column of small icons, with the fi le name, size, type, and the date and time the 
fi le was last modifi ed listed to the right of each icon.

NOTE
You can move, resize, close, and minimize Windows 
Explorer as you do other Windows applications.

PROFESSIONAL TIP
Windows makes extensive use of shortcut menus. Practice 
right-clicking inside windows and dialog boxes or when 
selecting folders and files. You will find that this method 
can speed up many operations.

Selecting and Arranging Contents
When performing functions such as copying, moving, renaming, and 

deleting, it is fi rst necessary to select one or more fi les. Pick to select a single 
fi le. To select a group of fi les listed together, pick a point that does not highlight 
a fi le, and then hold and drag the cursor to highlight the fi les to select. Release 
the pick button to complete the selection. To select a series of consecutive fi les 
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within a list, pick the fi rst fi le to select, hold [Shift], and then pick the last fi le 
to select. All fi les between the two selected fi les become highlighted. To select 
more than one nonconsecutive fi le within a list, pick the fi rst fi le, hold down 
[Ctrl], and pick the other fi les. Use the arrow keys to locate and highlight a single 
fi le. This selection method also supports [Ctrl] and [Shift] combinations.

Selecting Multiple Groups of Folders and Files
Apply the following steps to select two or more groups of consecutive fi les:

 1. Pick the first item in the first group then hold [Shift] and pick the last 
item in the group.

 2. Press [Ctrl] and select the first item in the second group.
 3. Press [Ctrl]+[Shift] and pick the last item in the group to select the second 

group.
 4. Press [Ctrl] and select the first item in the third group.
 5. Press [Ctrl]+[Shift] and pick the last item in the group to select the third 

group.
 6. Continue in this manner until you have selected all groups.

Use the following technique if the fi les or folders you need to select 
outnumber those that will remain unselected:
 1. Pick Select All from the Edit pull-down menu or press [Ctrl]+[A] to select 

all folders and files in the current drive or folder.
 2. Deselect the items you do not want to be part of the selected group by 

holding down [Ctrl] and picking the item(s) to remove.
The following is a good method to use if only a few files or folders are to 
remain unselected:
 1. Select only the files that are not to be acted on.
 2. Pick Invert Selection from the Edit pull-down menu to deselect the items 

you picked and select all remaining items.
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PROFESSIONAL TIP
The status bar at the bottom of Windows Explorer displays 
the number of objects selected and the total number of bytes 
in the selected items. Check the status bar when selecting 
files to copy to storage media. You can quickly see if the 
total file size exceeds the storage capacity of the media.

Arranging Folder and File Icons
Once you select the display that suits your needs, you can quickly arrange 

the icons using one of four methods available from the Arrange Icons by menu of 
the View pull-down menu. The Name method displays folders and fi les alpha-
betically, with folders listed fi rst. The Size option lists folders fi rst, and then 
displays fi les from smallest number of bytes to largest. The Type method orga-
nizes fi les by fi le type. Folders appear fi rst, and then fi les appear alphabetically 
according to the three-letter fi le extension. The Modifi ed option organizes fi les 
by the date they were last modifi ed.

When displaying icons in the thumbnail, tiles, or icon format, you can choose 
to move contents manually, or you can use the default Auto Arrange option to 
arrange icons in rows and columns automatically. To toggle Auto Arrange on 
and off, select Auto Arrange from the Arrange Icons by cascading menu of the 
View pull-down menu. A check mark means the option is active. When Auto
Arrange is off, you can freely pick and drag icons to new locations.

If your arrangement gets too confusing, you can align icons into the nearest 
rows and columns by picking Align to Grid in the Arrange Icons by cascading 
menu. This option does not produce the compact arrangement Auto Arrange
provides; it moves icons to the nearest row and column. Gaps may remain in 
the arrangement.

The Show in Groups option in the Arrange Icons by cascading menu 
arranges the icons in groups, labeled according to the criteria used to sort the 
fi les. For example, if you select the Size viewing option, the group labels might 
be Tiny, Small, Medium, and Large. If you select the Modifi ed viewing option, the 
groups labels might be Today, Yesterday, Earlier this year, Two years ago, and A 
long time ago.
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NOTE
When the Details option is active, you can automatically 
reverse the list order by picking any one of the column 
headings in the contents pane. For example, pick Size to 
display files first from largest to smallest, followed by the 
folders. Pick Size again to return to the default display of 
folders first, and then files from smallest to largest. Test this 
feature by picking each column heading.

Launching Applications with Windows Explorer
Many of the fi les that appear in Windows Explorer are associated with 

application programs. Double-click on the fi le icon or name to load the fi le and 
simultaneously start the application with which it is associated. For example, 
double-click on a drawing fi le to load AutoCAD, if it is not already running, 
and open the drawing.

File Management with Windows Explorer
Windows Explorer is an effective means of managing folders and fi les. For 

example,  you can rename, copy, delete, and move fi les from within Explorer.

Moving Folders and Files
One option to move folders and fi les is to highlight the folders or fi les to 

move and press [Ctrl]+[X] to move the selection to the Windows Clipboard. Then 
navigate to the folder in which you want to place the items and press [Ctrl]+[V]
to paste them into the folder. If you use this method, the fi le and folder icons 
are shadowed in the original folder, but do not disappear until you complete the 
paste operation. If you cancel before you paste, the items remain in the original 
location.

The second method is to open two instances of Windows Explorer. In one 
window, navigate to the current location of the fi les and folders to be moved. In 
the other window, navigate to the folder in which you want to place the fi les and 
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folders. Highlight the fi les and folders to be moved in the fi rst window. Then 
drag the fi les and folders to the other window.

Copying Folders and Files
One option to copy folders and fi les is to highlight the folders or fi les and 

press [Ctrl]+[C] to copy the selection to the Windows Clipboard. Then navigate 
to the folder in which you want to place the copies and press [Ctrl]+[V] to paste 
them into the folder.

The second method is to open two instances of Windows Explorer. In one 
window, navigate to the current location of the fi les and folders to be copied. In 
the other window, navigate to the folder in which you want to place the copies. 
Highlight the fi les and folders to be copied in the fi rst window. Then hold down 
[Ctrl] and drag the fi les and folders to the other window.

NOTE
Be sure to hold down [Ctrl] while you drag selections. If you 
do not, the items will move from the first location to the 
second, without creating a copy.

Renaming Folders and Files
To rename a folder or fi le in Windows Explorer, slowly double-click the 

folder name to activate it for editing. Type the new name and press [Enter] or 
pick anywhere on screen to accept the new name.

PROFESSIONAL TIP
Be sure to include the three-letter file extension when you 
rename files in Windows XP. A Windows alert informs 
you the file may be unusable if you change or omit the 
extension.
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Deleting and Restoring Folders and Files
In Windows, the Recycle Bin stores the items you delete from the hard 

drive. Select the folders and fi les to delete, press [Delete], and pick Yes in the 
confi rmation dialog box to send them to the Recycle Bin. 

If you delete the fi le from a network or removable drive, the dialog box will 
ask if you are sure you want to delete the fi le. Items deleted from network and 
removable drives are deleted permanently and are not sent to the Recycle Bin. 
Pick Yes to delete the fi le permanently. You can also delete fi les and folders by 
selecting the items and picking the Delete button at the top of the Explorer window. 
Pick Yes in the confi rmation dialog box to send the fi le to the Recycle Bin.

The Recycle Bin is a storage area for deleted fi les. If for any reason you need 
to retrieve a deleted fi le, open the Recycle Bin, right-click on the fi le, and pick 
Restore. The fi le moves to its former location in the folder structure.

Occasionally, you should review the contents of the Recycle Bin and empty 
it to reclaim space on your hard drive. Open the Recycle Bin and select Empty 
Recycle Bin from the File pull-down menu. Pick Yes in the confi rmation dialog 
box to delete the fi les permanently from the hard drive. Be sure that you no 
longer need the fi les before deleting them in this manner, because once they are 
removed from the Recycle Bin, they are much harder to restore.

Managing File Properties
To display detailed information about any folder or fi le, select the fi le and 

pick Properties from the File pull-down menu. Alternatively, you can right-click 
on the fi le name and select Properties. See Figure 2A-3.

Creating a New Folder
Use as many folders as necessary to organize project and system fi les. To 

create a new folder, pick the drive or folder icon where you want the new folder 
to appear. Then pick Folder from the New cascading menu in the File pull-down 
menu, or right-click in the contents pane and pick New and Folder. A New Folder
icon and label appear in the contents pane. Type a new name and press [Enter]. 
The folder is now ready to use.
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PROFESSIONAL TIP
Avoid saving files in the AutoCAD program folders. 
Always check with your instructor or supervisor before 
creating new folders or performing any disk management 
function.

Maintaining Removable Disks
You can perform a variety of operations on a removable drive, such as a 

fl ash drive using Windows Explorer. Each function is located in the shortcut 
menu that appears when you right-click on the Removable Disk icon. See 
Figure 2A-4.

Figure 2A-3. The Properties dialog box displays details about the file.

File name

File
information
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Formatting a Removable Disk
Formatting prepares the disk so you can copy information to it. If the 

removable disk you intend to format has been used, Windows Explorer detects 
this and informs you before it removes any existing data from the removable 
disk. Follow these steps to format a removable disk:
 1. Insert the removable disk into a USB port.
 2. Right-click on the flash drive name or icon and select Format... to display 

the Format dialog box. See Figure 2A-5.
 3. Select the capacity of the drive to format from the drop-down list in the 

Capacity: list box.
 4. If you want to provide a label for the drive, enter the name in the Volume 

label text box.
 5. Pick the Start button to begin formatting the flash drive.
 6. When formatting is complete, pick the OK button.

Right-click
on the

Removable
Disk icon

Shortcut
menu

Figure 2A-4. This shortcut menu appears when you right-click on a removable disk drive icon.
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Additional Disk Management Functions
The shortcut menu displayed when you right-click on the removable disk 

icon provides several other functions for managing the contents of removable 
disks. Select Expand to expand one branch of the folder tree for the selected 
drive. Pick Explore to display the contents of the fl ash drive in the contents 
pane. Choose Open to open a separate window displaying all folders and fi les 
on the fl ash drive. Select Search to open a new Windows Explorer window 
with the Windows Desktop Search or Search Companion active. Pick Sharing and 
Security to confi gure sharing for the selected drive. Select Properties to open 
the Properties dialog box.

Drag-and-Drop Operations with 
Windows Explorer

The drag-and-drop functionality in Windows makes many common 
Windows Explorer operations faster and easier, including copying, moving, and 
deleting fi les and folders. In addition, Windows Explorer allows you to drag 
and drop fi le icons into the AutoCAD drawing area to open drawings, insert 
drawing fi les as blocks, insert text fi les as multiline text, and import PostScript 

Select
capacity

Enter a
label

Figure 2A-5. The Format dialog box.
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and raster fi les. You can also use drag-and-drop operations to load menu, line-
type, shape, script, and slide fi les, as well as AutoLISP and ARX applications. 
Figure 2A-6 lists drag-and-drop operations possible with AutoCAD and the 
chapters in the text where you can fi nd additional tool information.

Dragging and Dropping a Text File
To drag and drop text created in a text editor outside of AutoCAD into a 

drawing, fi rst start AutoCAD and Windows Explorer and arrange the display 
windows so both are visible. Then, in Windows Explorer, open the folder 
containing the text fi le to insert. Finally, select the text fi le icon, drag it into the 
AutoCAD drawing area, and release the mouse button. The text inserts as a 
multiline text object in the current text style and on the current layer.

PROFESSIONAL TIP
If you use the right mouse button when dragging a text 
file into AutoCAD, a shortcut menu offers additional 
options. The Insert Here option produces the same result 
as a regular drag-and-drop operation. Optionally, you can 
attach a hyperlink to an existing drawing object or cancel 
the operation. AutoCAD and Its Applications—Advanced 
explains using hyperlinks in AutoCAD.

Operation File Extension Related Tool Related Chapter

Load a linetypes file LIN LINETYPE Chapter 5

Insert a text file TXT MTEXT Chapters 9 and 10

Load a shape font SHP COMPILE Chapters 9 and 10

Insert a drawing file DWG INSERT Chapter 24

Open a drawing file DWG OPEN Chapter 2

Print a drawing DWG PLOT Chapters 5 and 29

Figure 2A-6. Drag-and-drop operations possible with AutoCAD.
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Using Drag-and-Drop to Print a Drawing
You can plot a drawing by dragging the drawing fi le icon directly to the 

appropriate printer icon. The drawing fi le icon you select opens in the drawing 
editor using the FILEOPEN tool. This tool allows you to open a fi le without 
using a dialog box. The Plot dialog box also appears, allowing you to modify the 
printing parameters as required and print the drawing. An alternative method 
of plotting a drawing fi le from Windows Explorer is to launch AutoCAD, and 
then launch Windows Explorer. Right-click on the drawing to print and select 
Print.

Dragging and Dropping Drawing Files into AutoCAD
To open one or more drawing fi les in AutoCAD using a drag-and-drop 

procedure, fi rst start both AutoCAD and Windows Explorer and arrange the 
display so both windows are visible. Then select any number of drawing fi les in 
Windows Explorer and drag the selected fi le icons to the title bar of the AutoCAD 
program window. You must remember to drag it to the title bar of the AutoCAD 
program window. Each drawing opens in a separate drawing window.

You can also use a drag-and-drop operation to insert a drawing into the 
current drawing session. This method is similar to the INSERT tool described 
in Chapter 25. The drawing you drag and drop becomes a block. Therefore, you 
may need to explode it after insertion, if you want to edit the objects it contains. 
To insert a drawing, drag it into the drawing area of the drawing into which 
you want to insert it. You can only insert drawings one at a time.

Use the right mouse button when dragging fi les into the drawing area to 
display a shortcut menu of options. The Insert Here option inserts the drawing 
the same way as a regular drag-and-drop operation. The Open option opens the 
drawing in a new drawing window. The Create Xref option attaches an external 
reference to the selected drawing, using the drop point as the insertion loca-
tion and default scale and rotation. The Create Hyperlink Here option creates a 
hyperlink to the drawing attached to a selected object. The Cancel option stops 
the drag-and-drop operation.


